Home App Docs Blog Github

Builder pixel breaks amp compatibility

Hey there,

The builder pixel img-tag that is inserted breaks amp compatibility.

Perhaps you could do <amp-img size="1" width="1" src="builder_pixel_url" layout="responsive" />?

Thanks!

Thanks for reaching out! I’ve passed this along to our engineering team who will work on getting this resolved.

Hi there,

Did this fix get merged?

Hi!

The fix hasn’t been deployed yet. We will keep you updated and let you know when it is :slight_smile:

Hi Maddy,

Do you have an estimate on when it will be released?

Kara wrote that this would be deployed last week.

Best,
Ismail

Hi @ismailp!

Just circling back to let you know that the fix was deployed this morning.

If you run into any issues or have any questions, let us know :grin:

Hi there,

I see that the html tag is correct but it’s still not amp compliant.

Getting error: Incomplete layout attributes specified for tag ‘amp-img’. For example, provide attributes ‘width’ and ‘height’.

The pixel needs a height or width. Please check: https://amp.dev/documentation/components/amp-img/

Hi @ismailp! Thanks for following up.

We are working on adding additional attributes! We will keep you updated :grin:

Thanks @maddy! Without the attributes of layout and width + height the amp document will be invalid.

Hi @maddy, any updates on this?

Hi @ismailp! Thanks for reaching out.

We have a fix for this, it will tentatively be deployed this week. We will make sure to keep you updated :grin:

@maddy perfect! Thanks!

Hi @ismailp!

Just looping back to let you know this fix has been deployed. If you have any questions, let us know :grin:

It’s still not valid.

Hey @kevva, let me have the engineers test this again and ensure our full fix went out, will report back shortly!

Hi @kevva, we’ve released a fix that should resolve the amp compatibility issues you were facing. Don’t hesitate to reach out if you have any additional questions!

Hi @kara! The fix seems to be working great!

Best,
Ismail

1 Like