Preview on isn't updating immediately

I want to integrate builder on a landing page with some data. Say I am trying to edit a text on builder. I am not able to see the change in unless and until I publish it. I have followed the documentation specified in the builder integration docs.
But I have followed this way of integration without following the automated integration.

Attaching the video link here:


Can you let me know if I am missing anything. Thanks

Hello @SelvaPrasath,

Thank you for reaching out and providing the details, including the recording. We appreciate your proactive approach in addressing this issue. To assist you effectively, we kindly request the following information:

  1. A snippet of your package.json, including details such as the NextJS version and version.
  2. Folder structure.
  3. The code snippet related to the integration.

Also, could you let us know if this issue is persistent to the specific page or occurs on other pages as well?

Thank you for your cooperation.

Hi @OmPrakash
Pls find the package.json file below

the image for the folder structure is

builder.tsx file:

page.tsx file under [[…page.tsx]]

This occurs across all the pages.

Thank you for sharing the details; it’s rather unusual. We will investigate and get back to you.

We haven’t been able to replicate it yet, it seems specific to your space. But not sure yet, we might need to do more digging on that.

The below is my package JSON snippet

"dependencies": {
    "": "^0.1.24",
    "": "^3.0.14",
    "": "^2.0.8",
    "next": "13.5.4",
    "react": "^18",
    "react-dom": "^18"
  "devDependencies": {
    "@types/node": "^20",
    "@types/react": "^18",
    "@types/react-dom": "^18",
    "eslint": "^8",
    "eslint-config-next": "13.5.4",
    "typescript": "^5"

Is the issue occurring on other spaces as well?

Appreciate @OmPrakash on your follow up on finding the root cause but unfortunately the issue still remains the same.
And Yes it occurs for other spaces as well. That is only for this code repository. I have tried with React app for another space it worked as expected (changes in the ui when I drag and drop). Ideally this issue only exist in next js across all spaces I see.

Thank you for your understanding, @SelvaPrasath . I’ve tested the Next.js example app from our public repository here, and it appears to be functioning correctly.

Would you be willing to give it a try, using your API key, and let us know if it works for you as well? If it does, you might consider comparing the implementation differences, which could help us pinpoint the issue more precisely.