Dynamic Data is not showing up on the pages

hi there !
I’m facing a strange issue in builder.

i have a feature grid from where i go on its detail page which is a " section model "
which display full information based on handle in url. where im showing some symbols through code and dynamic data section which comes from builder with drag & drop options.

-when i create feature content from my model it will be like:

Which is correct and i can drag & drop components in normal way. and can publish.

when i re-open the feature to edit it further all the drag & drop content show for a fraction of second and then go away and i can’t view my drag & drop stuff while other things remain same:

-when i change my locales from one to another thos components re-appears randomly sometimes on mobile preview window sometimes on desktop preview window in builder… their output is absolutly correct when i visit the url. and that is not happening in localhost aswell.
this is fiddle : if u change locale you will see content for a few seconds and it just disappears : Builder.io: Visual Development Platform

@manish-sharma can you please help me in this issue ?

Hello @mohsin,

Looking into this right now!

Hello @mohsin,

Is the <Component {...data } /> a builder component? Can you share the screenshot of the code for it?


i have different types of models of detail pages where im using this same component and im passing my Detail page ( unique design of each model’s detail page ) as Component … and after that the next component is representing the drag & drop content…

when i create my content from any models and edit its detail page everything works fine. next time i revisit it and the only drag & drop content show for a bit of second and then go away if i change locale it may display on mobile preview or desktop preview … just happening randomly

Hello @mohsin,

We suspect that the issue may be related to dynamic data not being available during the render. Have you noticed any errors in the browser console that could provide further insight into the problem?


these are the errors on vercel which are triggering when opening edit of detail page

@manish-sharma there is no console error when i use localhost as baseUrl

this error occurred to me once an it was a caching issue, can you check after some reloads if the correct cont is showing?

@gustavoFreire @manish-sharma i tried reloading etc … didn’t worked aswell let me show the console im getting…

console is getting mobx error almost every few milli seconds. what can i try other ?