Editor doesn't reload after making changes

Hello I have a website using Builder.io + Qwik and on the CMS when I doing changes the editor doesn’t automatically refresh the page. I have to do it manually and is time consuming to do a simple change.

Any suggestions?

Thank you

Hello @Blas,

Welcome to the Builder.io forum post.

Could you please confirm which version of “@builder.io/sdk-qwik” you are currently using? Additionally, if you could share the Builder content link where we can test this issue, it would be much appreciated.

You can find more information about the changes in the “@builder.io/sdk-qwik” version in the following link: Builder.io SDK Qwik Changelog

Thank you!

Hello @manish-sharma

Thank you for your response.

We are using the following:
@builder.io/qwik”: “^1.3.0”,
@builder.io/qwik-city”: “^1.3.0”,
@builder.io/sdk-qwik”: “^0.4.5”

And the Builder content link is: Builder.io: Visual Development Platform

Thank you fro your help :slight_smile:

Hello @Blas,

Could you please upgrade to the latest Qwik SDK version, which is 0.14.0 and let us know how that works for you?

Hello @manish-sharma,

I have tried uploading the package however, when I upload it to the server (Azure) I got an error 500 due to: Error: Worker was unable to load function render: 'Cannot find module ‘isolated-vm’.

Any suggestions?

Thank you,
Blas

Hello @Blas,

Can you try adding NODE_OPTIONS=--no-node-snapshot to the command that runs your server?

Hello @manish-sharma,

Thank you for your help, tried that but doesn’t seem to work. Also, it seems that solution is for Mac M1 which is not my case.

Will try to investigate further in case there is something else we could do.

Hello @Blas,

You can try using a different node version!

Heelo @manish-sharma,

Thank you for your help.

Tried with version 18 and still have the same issue:

Hello @Blas,

Are you using LTS version of node?

Hello @manish-sharma,

Yes tried with 18 and 20 latest LTS versions and same problem, I think it’s something to do with Azure it self as when I try locally on dev mode and preview all seems to work fine.

If the issue is related to the node version on Azure, then adding --no-node--snapshot to the build command has been a successful solution for previous customers facing similar challenges. This flag helps to disable Node.js snapshots, which can sometimes cause compatibility issues or performance problems, particularly in certain deployment environments.

Hi @manish-sharma ,

Tried again with the flag after removing node_modules folder and ran npm install. What is happening is when running npm run preview or running the pipeline on the server it times out before finishing build.

Hello @Blas,

Are you getting any errors before the build timeout?

Hi @manish-sharma,

Fixed the timeout error but still have the same issue about isolated-vm. I’m considering not using qwik and use a different tool, could you please let me know which one is the best one to use?

Hello @Blas,

You can use NextJs, Vue or any other framework you are familiar with

Hello @manish-sharma,

Just a quick update, I found out that if you click crtl + Y on Builder.io editor it opens the developer settings. If I enable Safe Mode then the editor preview refreshes when making changes, so all fixed.

Still cannot update to latest sdk-qwik version due to the isolated-vm issue but at least can edit the pages.

Thank you for your help