Internal linking from richtext


We use sometimes in our pages the richtext editor and add internal linking:
For example, here in the grid list:

This /business/calculator page is localized, so we added in each localized list the correct url format
like this:



etc, for other languages as well.

The issue is, when we navigate from the real page, through this link, it won’t detect our locale, and try to redirect the default fallback locale which is hungary in our pages.

But when I click on it, the url won’t have the DE locale prefix:

(Link for trying it out:)

For our custom buttons it works perfectly the locale will stay the same like the user currently on.

How can we have this feature, without too much extra code, and replace every url with the /LOCALE/url version in the richtext, or is it the only way to solve it?

let me know


Hey @radikris ! I see this seems to be resolved, what was your fix? Was it just to manually enter in the /locale/?

Unfortunately I think this is somewhat expected behavior for a relative path as it will add the path after the main domain. Let me know if you used a different route to solve it!

Yes, I did it the manual way.

Can you please help me for this very dumb, but important question:

I want to manage headings for my Text input (without using this customcode solution

And I simply want to make this text field H2:
but there is no option for it, like in the richtext editor:

But if I don’t bind, there is the option:

How can I fix this quickly with my bindings and everything should stay the same just add the extra h2, I need this ASAP. Please let me know!


Hey @radikris you can edit an element’s binding in the data tab by selecting Edit Code and use a template literal, or by concatenating strings to achieve this, check it out:
Screen Shot 2022-05-24 at 11.03.58 AM