Builder editor removes focus from input element within iframe

Detailed steps to reproduce the bug
Go to the editor, click any input, try to type, notice the focus is removed and text is not populated

We have builder sections that are behind user auth. This prevents us from logging in via the iframe to access our content sections.

Since the iframe is considered a 3rd party, it doesn’t send the session cookie if logged in on another tab. We have tried installing the Chrome extension, but figure we still need to login via the iframe to trigger the Set-Cookie override.

Hello @jtcf,

Welcome to the forum post.

I wanted to inform you about recent changes to Chrome’s cookies policy, which have affected our Chrome extension. Unfortunately, the extension can no longer override cookies. As a result, you may need to adjust your cookies settings to enable editing content within the iFrame.

On another note, we’re actively working on an extension for Firefox that will address this issue. If all goes well, it should be available soon.


The cookie is an adjacent problem. Is the input focus fixable?

Hello @jtcf,

You can try the option “Enable Preview Iframe form submission” from the Models → Page Model → Advanced option and see if that helps allow you to submit the form from iFrame.

Thanks for pointing that out, that does allow me to submit the form now.

Unfortunately, it still doesn’t set the cookie so we need to wait for the Firefox extension.