Home App Docs Blog Github

Connect Your Domain not working

I am not able to connect to the domain.

I made the DNS changes and it said OK, but I still get a 404 when trying to access the URL. Which means the DNS records are okay but I cannot view a published page.

Neither can I use the internal URL to view a published page.

My domain is docsupplies.org - and this seems okay:
image

I have also changed the subdomain here:
new users can’t upload more than one embedded item - wow, what a fantastic policy for your new customers!

Even though the domain is ‘connected’ it still shows nothing here:
new users can’t upload more than one embedded item - wow, what a fantastic policy for your new customers!

I have published the page:
new users can’t upload more than one embedded item - wow, what a fantastic policy for your new customers!

But when I browse to docsupplies.org/about, I get this:
new users can’t upload more than one embedded item - wow, what a fantastic policy for your new customers!

View current draft gets me a blank page:
new users can’t upload more than one embedded item - wow, what a fantastic policy for your new customers!

View live page is 404

Builder public api key
2793b43dc9424500b5b50f4270253906

I need help with:

  1. Connecting my domain - it is actually connected - because the DNS records (I use namecheap for what it’s worth) have been accurately modified and applied.

  2. Until I am developing this website - How do I noindex this site?

Thanks

Thank you for the detailed report Bhavesh - with this info our engineers were able to quickly jump in, diagnose, and resolve your issue. You should be good to go now - let us know if this is no longer resolved for you and we will give it another deeper look. We will also work async to diagnose why this edge case happened to you and make sure it doesn’t happen to future users

@bhaveshdhaka , for adding noindex meta tags to your pages, please follow this post How to add meta tags / Custom head html to my page entries?

Thank you @aziz

I am not sure if I am doing this right, I followed the instructions.

Added the code in the JS:

image

Published the page.

But when I view the source, I still can’t find ‘noindex’.

I can now view / access the site. The DNS issue appears to be resolved.

Just curious as to why I still see ‘CONNECT’ under ‘Connect your domain’. I believe it is already connected.
I have learned about the editor, connected my domain, don’t want to add teammates right now and I Know where to go to reate a model, add custom components etc.
So maybe I don’t need the onboarding section anymore?

Hope that makes sense!

Another unrelated question - what are the pefromance / rendering metrics of sites built on builder.io? I am currently evaluating several JAMstack combinations for my upcoming projects and would be interested to know if there is any.

I found this post - A first look at Qwik - the HTML first framework
However it had no date and I wasn’t able to understand if Qwik was already live and what sort of PageSpeed scores we can get.

Hi Bhavesh!

We are seeing the meta tag being added correctly to your site. Would you mind doing a check across another browser or disabling the cache? You can disable the cache in the Network tab of the dev tools panel (right-click > Inspect).

This is valuable feedback for the user experience. You’re right–this should now indicate in some way that there is already a connected domain to close the feedback loop. I’ve added it to our internal collection of feature requests.

We can talk about this more in another forum post and involve the team at Builder that focuses on page speed and loadtimes, if you’d like. Let’s keep this thread focused on the subject header.

Regarding Qwik, there are some technical examples in the repo, and there is an active Discord community (link in repo) where you can learn more about its current status.

1 Like