REST API query doesnt seem to properly work

I’m trying to make a REST query to my models so I can implement a site search.

I have a page title:
The dev test page

When I query without a value I get all the pages:$regex=

Tried everything to filter, but the results always are empty:$regex=/dev/

Hello @chrischris,

Welcome to the forum.

This works for us$regex=.*dev.*&limit=1&omit=data.blocks

You may also find help at

Hi @manish-sharma ,

Still empty results, tried both .dev. and the JSON5 approach.

{"results": []}

Hello @chrischris,

Would you be able to help us with your builder Public API Key? You can find instructions for finding it at this link.

@manish-sharma absolutely, there you go:

Thanks for helping with this.

Hello @chrischris,

I’m not able to see any content with the title “dev”, When I try to query the page model for content with the title “Download” it works$regex=.*Download%20.*&limit=1&omit=data.blocks

It only works with the page model, doesn’t seem to work with any other models Which is what we’re trying.

We have the model:

Hello @chrischris,

It seems to be working for us, the query is returning the correct results$regex=.*Dev.*&limit=1&omit=data.blocks

I’ve just realised what the issue was, case sensitive as I was looking for “dev”, instead of “Dev”.

adding this to the query solved it:

Thanks, @manish-sharma, you are a life safer!