Saved changes not reflecting outside of Builder editor

Builder content link

Builder public api key

What are you trying to accomplish
I want to see the changes saved after publishing changes in Builder. The changes reflect in the builder editor, but they do not reflect outside of Builder(in NEXT.js). When logging the results of the fetch query, we see the data is stale.

Code stack you are integrating Builder with
Front-end: NEXT.js 14
Builder SDK: SDK Gen 2

Reproducible code example

const content = await fetchOneEntry({
    model: "page",
    options: {
      cacheBust: true,
      cacheSeconds: 10,
      staleCacheSeconds: 1,
    userAttributes: { urlPath: "/" },
    apiKey: process.env.NEXT_PUBLIC_BUILDER_API_KEY,

What have we tried
We tried many if the solutions from the forum & the docs. We tried passing the settings on an options prop as well as on the root object itself.

Hello @CourseStudio,

Upon reviewing the live page at, it appears that the content has been successfully updated. However, to ensure accuracy, could you kindly provide us with a screenshot highlighting the specific section or data that is not being updated as expected?

Looking forward to your response.

Hi Manish,


When in the Builder editor, we’re updating a link that used to point to, to

When hovering over the link in the Builder editor preview, the link target reflects the new updated URL.


When hovering over the link outside of the Builder editor preview after publish, the link still reflects the old link.

We’ve experienced this with any changes we make on the content.

Hello @CourseStudio,

We’ve been investigating the issue and have verified that the API key is correctly set up. However, we’re still unable to pinpoint the exact issue. We suspect that there might be a problem with the Builder integration, but it’s challenging to troubleshoot without more information.

Would you be able to record a video showcasing the integration code and your Vercel setup? This would help us better understand the issue and provide more targeted assistance.

Looking forward to your response.

Hi Manish

Thank you for getting back to us. Please have a look at this Loom video. I can share additional bits of code upon request.

Hello @CourseStudio,

The Gen 2 SDK currently don’t support the cachebust: true param and
instead of includeRef, you will need to use enrich: true

Hello @CourseStudio,

For some reason nothing seems to be updating for your content, I’ve performed a test on blog articles and the landing page. Therefore, I would recommend

  1. try purging the cache from the Vercel

  2. Instead of using the API key from the env variable, try setting them directly in the Content and fetchoneEntry

  const content = await fetchOneEntry({
    options: getBuilderSearchParams(props.searchParams),
    model: builderModelName,
    userAttributes: { urlPath },
<Content content={content}  apiKey={PUBLIC_API_KEY_NOT_FROM_ENV} model={model} customComponents={customComponents} />;

Hello @CourseStudio,

We have further investigated the issue, and it seems that any changes to the builder content are reflecting well on our content API calls. However, changes are taking around 48 hours to reflect on the Vercel deployment. The “Contact us” URL is now updated, and we suspect this delay is due to Vercel deployment and data cache. Therefore, we recommend checking out the link below which may offer possible solutions:

Thanks Manish for the help here. I cleared that data cache and the changes reflected immediately. Thanks for link the article from Vercel. We’re going to look at figuring out how to keep the data cache clear for new content