Some images are not fetched from the CDN on mobile

Builder content link

Builder public api key

Detailed steps to reproduce the bug
It seems that lately some images are not being loaded/fetched from your CDN.
We can select the image from the File manager and can see a thumbnail in the Block Options tab, but in the viewer, the images are not loaded. However, when loaded on a mobile or the browser is in mobile mode, the images load just fine.

Screenshots or video link
Browser in desktop mode

Browser in mobile mode

Code stack you are integrating Builder with

Hi @rasmussyberg,

We are not able to reproduce this possible issue, could you please check the browser console and let us know if there are any errors when images aren’t loading?

Hi @manish-sharma

There are no errors in the console, and the network status response is 200 for all images.
However, the ones that do not work respond as content-type text/html instead of jpeg.

I tried out using to see if it was different results around the world.
On this address, I get the same result as you can see in this image

Hi @rasmussyberg,

All images loaded fine for me, both in the editor and in live mode.
However, when we reduced the zoom (say < 80%) the image rendering broke and showed white containers with broken-image browser icons. Tried opening the image link manually and our API was returning an error.

Could you switch to a different image format and try, say jpg or png ?

This could be an issue with webp rendering in the browser. Firefox at least renders at zoom levels > 80 but Chrome does not render at any zoom level apart from the initial zoom level. We are investigating this further and will be sharing an update as soon as we have any insights into this. Thank you!

Hi @manish-sharma

Switching the images out with new jpg formatted images seems to solve the problem. We did indeed have problems with many of the uploaded images that initially were in webp format.

1 Like