Troubleshoot Pop up shows every time preview loads

Hi guys, is there a way to limit troubleshoot pop up, or at least to wait more for reloading the page… We are using dynamically generated preview URL and every time it reloads, although the page is valid it appear the troubleshooting popup.

Here is the code that we’re using on preview (I’ve changed a bit to make more readeable).

const url = 'https://staticURL/products/';

const res = await fetch("https://myURL/graphql",{
    method: 'POST',
    headers: {
        'Content-Type': 'application/json'

const data = await res.json();

if(data) {
  return `${url}${data.permalink}`;
    return "";

Thanks in advance!

Hi @hyden ,

Welcome to the forum.

There seems to be some issue accessing the URL which is setup on your builder account, can you confirm if this is an active URL?

Hi manish, yeah, that URL is no longer active, but that’s not the problem. I tried it with an URL that works. It seems that it takes to long to load, but eventually loads the page… so I’m thinking is there a way that can change the timeout settings?

Hi @hyden,

This has been a known issue, and we are checking to see if there is a way to change the timeout setting, we will keep you posted as soon as we have any insights on this. Thank you!

1 Like