"View All Templates" dialog does not update its state when deleting a template

Builder content link
Not bound to specific content

Builder public api key
590f4251081d402c96f40922159dcfc5

Detailed steps to reproduce the bug
Go to “My Templates”, click the “View all Templates” button. Select edit on a template and delete it. Nothing happens to the list of templates. Have to close and re-open dialog to see updated list of templates.

Hey @tobias.akeblom Welcome to the Builder forum. After conducting tests on my end, I was unable to reproduce the reported issue. Additionally, I created a test template in your space and successfully deleted it without the need to refresh the page. This leads me to believe that the issue may be related to cache.

Could you please try this in incognito mode to see if the problem persists? Also, if there is a specific template you are attempting to delete, kindly let me know so that I can further investigate the matter.

Hi, thanks for responding. I just tried in inkognito and the problem is still there. It is not bound to any specific template.

Would it be possible to share a loom recording of the issue?

Sure thing, here it is.

Tobias testar | Visual Editor | Builder.io - 21 February 2024 - Watch Video

Hey @tobias.akeblom
I am happy to confirm that I was able to reproduce the issue you are experiencing thanks to the details and steps you have provided.

I will now discuss the issue internally in order to determine the next steps. Once I have further updates, I will get back to you.

In the meantime, Please feel free to reach out with any questions or further details you may have.